
 

 

  

FOREX TESTER 4    

USER GUIDE   

To see the Forex Tester 3 User Guide please click here  

   
   

https://forextester.com/templates/doc/QuickStartGuideFT3.pdf
https://forextester.com/templates/doc/QuickStartGuideFT3.pdf
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Quick Start    

Download Forex Tester and install the software.    

   

See also "Installation" on page 25   

The downloaded version already contains 1 month of historical data on 16  

currency pairs as well as the gold and the silver rates.    

     

https://forextester.com/download
https://forextester.com/download
https://forextester.com/download
https://forextester.com/download
https://forextester.com/download
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Working with Forex Tester 3, you need to do three things:    

   

1. Download more data to test custom time periods.   

2. Create a project with unique settings.   

3. Start Testing process.   
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Testing process    

1. Click the "Start Test" button to initiate the test.   

   

2. Click the "Pause" button to stop the test. To resume the test, press the  

button again   

   

3. Change the speed of testing by moving the slider to the left in order to slow   

   

and to the right for accelerating the bars movement.    

   

4. Move forward by one bar every time you press the "Space" key on your  

keyboard or clicking the "Space" button on the toolbar   

   

5. Scroll to one bar back whenever you press the "Backspace" key on your  

keyboard or clicking on the "Backspace" button on the toolbar   

   

6. You can change the time frame with the help of the special drop-down menu   

   

7. You can change the size of the tick package by clicking the corresponding  

drop-down menu.   
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If your current time frame is equal to the value of 1 hour, and the tick 

package size is equal to 5 min, then the program will have to change the 

price 12 times before moving to the new bar (60 minutes / 5 minutes = 12)  

See also "Start testing" on page 94   
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Download data    

1. Click the “Data Center” button on the toolbar   

   

2. Highlight a currency pair and click the "Update from sever" button  

   

3. Download the history fully or select the date range and click the   

“Update” button.   

See also "Data Center"  on page 62   
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Create a project    

1. Click the “New Project” button on the toolbar   

   

   

2. Enter the Project name and click “Next”   

   

   

3. Choose the currencies that will be available within the project   
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4. At this stage you can make use of the following additional   

settings:   

• Add an automated calculation of the time shifting for a trading 

session  

you are interested in;   

• Apply the time settings of the New York Close or London Close in 

the case  

you trade in a time zone other than these sessions;   

• Choose “Forward testing only” mode if you want to check the real 

trading  

environment without the possibility to step back.   

5. Click “Create”. Test will start automatically.   
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See also "Creating new projects" on page 82   
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Pending orders opening    

1. Go to the "Orders → New pending order" menu or click on the “P” button on  

the toolbar:   

   

2. Click once on the drop down menu and select the required type of the order   

   

Please note that limit orders should be used when you expect the price 

to reach some level and then bounce from it, whereas stops orders are 

made for breakthrough strategies. If you think that the price will go up, 

reach a certain point, and then resumes the downward movement, then 

you should set a “Sell Limit” order. If you expect the price to go down 

and breakthrough the support level, then it is necessary to open a “Sell   

Stop” order.    
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3. Choose how to calculate the lot - manually or based on risk management. 

Note that if you choose a risk-based lot calculation, you should enter a Stop  

loss value.   

   

4. Select the price at which the order must be opened   
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5. Enter the Stop loss and Take profit values   

   

   

   

6. Click the "Place" button.   
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  See also "Placing Orders" on page 98       
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Market orders opening    

1. Go to the "Orders → new market order" menu or click on the “blank sheet”  

button on the toolbar:   

   

2. Choose how to calculate the lot - manually or based on risk management. 

Note that if you choose a risk-based lot calculation, you should enter a Stop  

loss value.   

   

3. Click either the "Sell" or the "Buy" button.   
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See also "Placing Orders" on page 98   
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Pending orders closing    

1. Release the pause key or click the "Space" button on your keyboard or click  

the button on the toolbar   

  

until the price reaches the stop loss or the take profit, or until you decide  

to close the trade manually.    

2. To close the order manually, double-click on the row of the desired order  

in the "Pending orders" tab in the lower left corner or the screen.   

   

3. Click the "Delete order" button   

   

   

See also "Closing Orders" on page 104   
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Market orders closing    

1. Release the pause key or click the "Space" button on your keyboard or click  

the button on the toolbar   

  

until the price reaches the stop loss or the take profit, or until you decide to  

close the trade manually.    

2. To close the order manually, double-click on the row of the desired order  

in the "Open Positions" at the bottom left of the screen   

   

3. Click the "Close position" button   

   

See also "Closing Orders" on page 104   
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Adding indicators    

To add an indicator navigate to the "Insert → Add Indicator" menu.   

In Forex Tester 4, we got all indicators grouped by their functions.   

   

   

To import custom indicators in .dll format into Forex Tester 4, use the File → 

Install → Install New Indicator menu. After importing, you can find your 

indicators in the Insert → Add Indicator → Custom menu.  See also "Using 

Indicators" on page 107   
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Historical news services   

In Forex Tester 4 we have added the historical news service as one of the major 

instruments of the fundamental trading.   

   

1. Go to “Data Center → News” tab in order to download the historical news.   

2. The Update News from server button allows you to immediately update  

the news.   

   

    

3. By default, the news displaying is enabled and they are represented at the 

bottom of the chart as flags. The color of the flag border (red, yellow, green)  

indicates the importance of this news.   
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4. To disable the displaying of news on the chart please use the right-click 

mouse button and uncheck the “Show news” item or use Right Mouse   

Click => Chart settings => Settings => uncheck the “Show news” option.   

   

   

   

See also "Using News Service " on page 152   
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Test analysis    

In order to analyze the test results, switch from the "Currency" tab to the 

"Statistics" tab in the "Market Info" window that is located in the upper left  

corner of the screen.    

   

To export the trade history to Excel, click on the tab Account History at the 

bottom of the screen, right-click on any line, and choose the   

Export History to File option.   
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You can see your Profit and Loss in points on the Account History tab in 

the Profit/Loss line. For convenient viewing of the account history,  

you can use various filters by clicking the Show Filters button.    

   

See also "Statistics and Account History" on page 146   
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Tracking bar parameters    

All the necessary information regarding each candlestick is reflected on 

the "Data Window" panel. This panel is located in the left bottom corner 

of the screen. You can see the date, time, open, close, high and low prices 

of the bar, which is hovered with the mouse at the moment. In addition,  

you can see values of volume, indicators and the index of the bar    
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Expert Advisers usage    

1. Go to the "Testing → Strategies list" menu   

   

   

2. Check the "Awesome EA" automated strategy Pick one of the 7   

built-in EAs to try in Forex Tester   

    

3. Double-click on the adviser’s name   
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4. Select the currency pair (in this case we need to select EURUSD)   

   

   

   

5. Set the time frame H1 (Timeframe 60)    
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6. You can leave the default parameters for the lot size and moving  

averages’ periods.   

7. Click the "Apply" button .   

   

8. Check "Enable strategies execution"   

9. Click the "Close" button    
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10. Click the "Start Test” button   

   

   

Make sure that the time frame of the chart corresponds to the time frame 

selected for the expert adviser (H1).   

To change the indicators’ parameters and style right-click on the indicator 

and choose the “Edit” option.   
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The Expert Advisor will automatically open and close the trades using the  

rules of strategy.   

   

See also "Expert Advisers" on page 140   
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Installation    

To install the Forex Tester 4 you need to download    

ForexTesterSetup.exe file from the Download page on our site. Please click 

“Download my free trial” button (or the button with the alternative  

name) to start downloading.    

   

When the file is downloaded, please launch the installer and click “Run” 

button when the next window appears. Click “Yes” if the operating 

system asks you to allow the program to make changes on your PC.    

http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
http://www.forextester.com/download
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Click “Next” when the Welcome to the Forex Tester Setup Wizard window 

appears.    

   

Please read the End-User License Agreement and confirm it by selecting “I 

accept the agreement” option.    

After this, click “Next” button to continue.    
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Select the folder where Forex Tester 4 program will be installed and click 

the “Next” button. We urgently recommend that you install Forex Tester 4 

into the default location (C:\ForexTester4). If you install the program into a 

C:\Program Files\ folder, the program may work with problems, so we do 

not recommend doing it.    
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Activate “Create a desktop icon” option for easier access and click “Next” 

button.    

      

After this, click “Install” button in the next window to complete the  

installation.    
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Wait until the program is installed on your computer. After the 

installation is complete, please activate “Launch Forex Tester” option 

and click “Finish” button to launch the program immediately. Or 

uncheck this option if you want to run it later.    
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Congratulations! The program has been installed on your computer.  You will 

see this icon at your desktop if you have chosen this option during  

installation.     
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Views    

Forex Tester provides its users with six chart modes. Three of them are situated  

on the toolbar and in the “View” menu.    

   

1. The first one is the Candlesticks mode.    

Candlesticks are set in Forex Tester 3 by default. Candlesticks are the vertical  

rectangles of two colors that might have upper and lower wicks.    

   

2. The second one is the Bar mode.    

This mode consists of the vertical bars with horizontal line segments.  

Vertical bars display the distance between the high and the low of the 

current bar, whereas the left horizontal lines show the open price of the bar 

and the right horizontal line provides information about the close price.    
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3. The linear mode, the third one, is the poly line that joins all the local  

maximums and minimums.    

   

   

4. The fourth mode is the Range bars mode. To switch to this mode please 

navigate to the “File → Add new range bar chart” menu and then click on 

the currency pair for which you need to create a Range bar chart.    



 

38   

   

   

After that, Forex Tester will ask you about the “Range bar size”. Insert the  

necessary value and click OK.    

   

You will notice that the spread of each candlestick or bar will be equal to the 

value that you have previously entered.    
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5. The fifth mode is the Renko bars mode. To enable it you need to navigate 

to the “File → Add new Renko chart” menu. Further, you should identify 

bar size in pips and click OK. Please note that Renko bars size is size of bars 

body without shadow.    
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6. Finally, the sixth mode is the Tick chart mode. It shows every single price 

change within a current data range. To switch to Tick chart you should  

click on “Ticks” tab in left upper corner of the screen.    

   

By default, all up-candles have a sea-green fill color. All down candles have a 

coral fill color. You can change the colors of the candlesticks and chart’s  

background by right-clicking on the chart and selecting the “Chart  

settings” option.    
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There are nine color schemes available in Forex Tester. Let’s change the 

default one to “Black on White” scheme. This inverts the fills’ colors and 

sets the black borders of the candlesticks. Now the bullish candlestick has  

the white fill whereas the bearish one has the black fill.    
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You can also alter the colors for the:    

• background   

• frame and text   

• grid   

• borders of the candlesticks   

• fills colors   

• and period separators   

Switch to the “Additional colors” tab and you will have access to other 

important lines that appear on the chart. By default, stop loss, take profit 

values, loss trades and buy order markers are colored in red. Orders’ levels, 

profitable trades, volumes and sell orders markers are painted in green 

color. You can change all of these lines and set any color you like using the 

dropdown menu to the right from each option.    
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In addition, you can switch to the “Chart settings” tab and check or uncheck 

many different options.    

You can deselect the “Show volume” checkbox – this will make a volume  

indicator disappear.    

When you open and close trades, the open and close points, become  

connected with a line. You can switch that line off if you need. In order to 

do that, please right-click, select the “Chart settings” option, choose  

the “Chart settings” tab and uncheck the “Show account history”  

checkbox.    

The “Show period separators” checkbox enables the dotted vertical line that 

appears at the end of each trading day.    

You can disable the “Grid” if you find it distractive. The grid is the set of dotted 

rectangles that simplify the navigation on the chart. Each grid’s line provides a 

trader with the information about the price and the time of the  

candlestick.    
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Period separators are dotted vertical lines that appear at the beginning of the 

day. Grid is the set of dotted rectangular that help to see the  

coordinates of any point on the chart.    

You can also enable or disable pre-cited parameters if you right-click on the 

chart and choose the necessary option.    

As an alternative, you can navigate to the “View → Chart” menu and find the 

same options there.    
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If it is more convenient for you to see the indicators and account history 

line beneath the candlesticks line then you can put to use the “Chart 

on foreground” checkbox.    

Bid level is the line that shows at which price the sell order will be filled if you 

open a sell market order.    

Likewise, the ask level is the line that shows at which price the buy order will be 

filled if you open a buy market order.    

You can enable or disable these lines in the “Chart settings” tab.   If you 

have an indicator on your chart, then its current value may be displayed with 

a red color at the price axis. You can enable/disable these options in “Show 

indicators’ values”.    

Right offset is the space from the last candlestick to the price axis. If you disable 

this checkbox, then no space will be visible to the right from the  

candlesticks.    

You can set the offset using the scrollbar.    
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If you enable the “Use fixed price range” checkbox, and then type in the 

values for the top and the bottom price you will be able to see the objects 

that are situated in this vertical range only.    

When the “Use fixed scale 1 pixel: 1 point” checkbox is disabled you will 

notice that the local maximum and minimum are always visible. If you enable 

the checkbox, then the vertical size of the candlesticks will be changed, and 

the changes will vary depending on the screen resolution of your monitor.  

By default, the grid’s horizontal line is drawn after each five pips. You can 

change this value if you enable the “Use fixed grid” checkbox and type in 

the custom value for your grid. Let’s type “30” in the “Grid points” input 

and click “OK”. This will increase the distance between the grid’s lines.    

To test the “Mouse sensitivity to lines” parameter you need to add a line 

to the chart. After that double-click on it, and use the drag and drop method 
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to reposition the element. If the value of the “Mouse sensitivity to lines” 

equals to 3 then even if you click 3 pixels away from the line it will still be  

moved.    

   

In the “All charts” tab you can change the scrolling speed, mouse and 

magnet sensitivity: as well as types of charts’ synchronization align type, 

thickness of bars and alignment of chart when time frame or scale change. If 

you set the scrolling speed’s value at 10, then you will be able to scroll 10 

times faster compared to the “1” value. To test it out click anywhere on the 

chart and hold. Then drag the mouse to either the right or left and you will 

see the speed of scrolling.    
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All charts with the same currency pair are synchronized by default and while 

scrolling within the same time frame, all other charts will be scrolled 

automatically with the right calculation. For example, while scrolling 1 bar  

forward on the H1 time frame, the M5 time frame chart will be 

scrolled 12 bars forward respectively. You can turn on/off  

synchronized scrolling by clicking on the button on the scrolling toolbar under  

the chart):    
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To make the candlesticks thinner and therefore to include more of them on the 

chart without scrolling:    

1. You can click on the “Decrease chart scale” button on the toolbar   

2. You can also navigate to the “View → Zoom out” menu   

3. At last, you can click on the “Minus” button on the calculator section of your  

keyboard.   

To make the candlesticks appearance more prominent:    

1. You can click on the “Increase chart scale” button on the toolbar   

2. You can also navigate to the “View → Zoom in” menu   

3. At last, you can click on the “Plus” button on the calculator section of your  

keyboard.   

To reposition the chart windows, please use the options from the “Windows” 

menu:    

1. Click “Cascade” to make the windows stacked one on another   
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2. Click “Tile horizontally” to make the windows stretched from the left to the  

right   

3. Click “Tile vertically” to make the windows stretched from the top to the  

bottom   

   

You can enable or disable any of nine panels available in Forex Tester. Please  

navigate to the “View → Show panels” menu and click on the desired panel:    

1. The “Symbol” panel displays all the currencies that are involved in the 

project. You will see bid and ask prices as well as the spread value   

2. The “Tick chart” shows the price changes within the current bar. On this 

example, you can see that the bar was opened at 93.41 pips. Then the price 

went down and reached the 93.35 value. At last, the bar was closed at its high 

level at 93.42.   

3. The “Statistics” chart provides traders with all necessary information on their  

strategy’s performance.   

4. The “Scripts” window contains all available scripts. Script is the algorithm that  

will be run once by the user’s demand   

5. The “Data” window includes the information on the current bar such as: the 

date and the time when the bar appeared, the open, high, low and close 

prices, the tick volume and the bar index. To get information on the bar you 

need to hover your mouse on it. In case if you want the information regarding 

some particular bar to be displayed all the time no matter if you hover on this 

bar or not, please make use of the “lock index” checkbox and set the index of 
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the locked bar. Please note that the bars count begins from 0 and not from 1. 

In  

addition, the calculation goes from right to left.   

6. The “Open positions” tab displays all opened orders   

7. The “Pending orders” tab shows the pending orders only   

8. The “Account history” tab shows all the closed orders   

9. The “Journal” provides users with the technical information on indicators 

that have been loaded, with orders placement, modification, and closing, with 

test  

start, end, etc.   

   

To clear the "Journal" you can use the "Clear journal" button on the toolbar   

   

10. "Notes". Here you can create a note using the Add note button and also  

see a list of all created notes. Another way to add a note is to click on the button        

on the Paint toolbar and select a bar to which the note will be linked after  

creation.   
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After that the “Edit note” window will be showed.   

   

You can set up date and time of the note, select one or all symbols to link the 

note, enter the Title of the note and text.   

You can quickly jump to the bar on the chart the note is linked with using double 

click on the note row.    

Using right-mouse click the on the row with a note (or on the icon       on the 

chart) you can see the menu which allowing you to edit or delete it.  

Another way to delete a note is to click on the Delete button.   

To hide notes icons on the chart, please use right-mouse click on any place of 

chart and uncheck Show Notes menu item.   

You have the ability to find the necessary note using the Search field. Please note 

that search works only through headers (names) of notes.   
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Forex Tester 3 is translated into 15 languages so you can experience using the 

software in your native language. To change the language you need to  

navigate to the "Tools → Language" and then pick the necessary option.    

   

If you navigate to the "Tools → Options" menu, you can notice 6 tabs in the 

window that appeared. The "Default orders" will be especially useful for 

you in case if you often open orders with the same parameters. For example, 

if your strategy requires opening of the order with the stop loss of 40 pips 

and the take profit of 60 pips with the same lot size of 0.2 then you can easily  
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set it up.    

1. Click on the "Add" button   

2. Set the "0.2" value from the dropdown menu that is situated to the right  

from the "Lot" option   

3. Enter "40" manually or using the dropdown menu near the "Stop loss"  

option   

4. Enter "60" manually or using the dropdown menu near the "Take profit"  

option   

5. Add a comment if you need it   

6. Click "OK"   

   

Now, you've added a default buy order. Whenever you need to open your 

standard order with the above-mentioned values, just make use of the   

CTRL + B shortcut.    
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The same procedure can be set for the default sell order that becomes placed 

with the help of the CTRL + S shortcut.    

The second tab is called "Hot keys". Here you can find out all the actions 

that are applicable in Forex Tester and find their Hot Keys equivalents. If you 

need to change the existing hot key value or to set one for a non-set value, 

double-click on the shortcut name and then select a necessary shortcut from  

the dropdown menu.    

   

On the “Time frames” tab you can add or delete default time frames, used for 

new projects.   
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You can add a custom time frame by clicking the Manage Time Frames button 

 on the Main toolbar. In the Edit Time Frames window, you  

can make this list of time frames default for your new projects by clicking  

on the “Make default” button.    
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You don’t need to create custom time frame for every new project – just do 

it one time and save your new list of time frames as a default list. When 

creating a new project, your custom time frame will be also represented 

among other default time frames.   

In the "Sounds" tab, you can set, delete or listen to the 4 sounds that exist 

in Forex Tester. These sounds represent the .wav files that will be played when 

you start or stop the test when an error or a successful action occur.    

To set your own audio file, click on the "Open file dialog" button.    

To delete the sound use the "Cross" button.    

To listen to the existing sound, click on the "Speaker" icon.  In the 

"Sounds" tab, you can set, delete or listen to the 4 sounds that exist 

in Forex Tester. These sounds represent the .wav files that will be 

played when you start or stop the test when an error or a successful 

action occur. To set your own audio file, click on the "Open file 

dialog" button.    

To delete the sound use the "Cross" button.    

To listen to the existing sound, click on the "Speaker" icon.    
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In “Updates” tab every user can set periodicity of updates from server requests. 

You can also disable this setting so the program never tried to  

update till the newest version.    
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In “Other” setting “Set pause after start test” can be activated. When this 

option is enabled, after clicking on “Start Test” button new bars will not  

appear till you click on “Pause”.    
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Data center    

Data Center serves as the manager of the historical quotes. You can:    

• Add/delete currency symbols.   

• Look through/edit the properties of the currency symbols.   

• Download minute historical data from the server.   

• Import historical data from files.   

• Download tick data from the server.   

• Group the currency pairs and change settings for multiple pairs at the  

same time.   

• Export data into CSV files.   

You can open Datacenter dialog window via File → Data Center menu:    

     

Or click on this toolbar icon:    

   

 

The window of Datacenter has the following view:    
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The upper green bar at shows the quality of the imported 1-minute data.   

The lower green band shows the quality of the imported tick history.  You 

can download free medium-quality data directly from the data center in  

Forex Tester or from our page   

If you want to get the most accurate results, then you can purchase paid  

data at an affordable price.    

Please note that using the lower quality data will most likely lead to less 

accurate testing results, which, in turn, may adversely affect the 

subsequent results of trading on the live accounts in case if you choose 

to use your trading system on the real market.    

The indicator at the bottom (the gray one with oblique lines on the  

screenshot) indicates the absence of tick data in this example. Tick data is 

extremely important for testing short-term and scalping strategies. If you are 

trading on M1-M30 time frames, then subscribing to the paid  

https://forextester.com/data/datasources
https://forextester.com/data/datasources
https://forextester.com/data/datasources
https://forextester.com/HistoryServiceDescription
https://forextester.com/HistoryServiceDescription
https://forextester.com/HistoryServiceDescription
https://forextester.com/HistoryServiceDescription
https://forextester.com/HistoryServiceDescription
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historical data will be a good investment.    

Please see the description of the main elements of the window below.    

1) The list of currency symbols:   

   

With the help of this list you can:    

• Select the currency symbol for further work. On selecting the symbol its 

detailed information and available actions are displayed in the  

right part of the window.   

• Delete the symbol(s) (Delete - button under the list). On clicking this 

button, all selected symbols will be deleted.  Add a symbol (Add -  

button under the list).   

• Select or deselect all symbols in the list for applying the group settings. 

For example, you can select all symbols in the list and download 

historical data for all symbols at the same time.   

You can also activate necessary pairs by checking the box to the left from the 

currency pair name and then apply group settings (download data,  
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change leverage, etc.) for multiple pairs.    

2) The description of currency symbol properties:   

   

You can change currency symbol properties with the help of the Change 

Properties button.    

In the Symbol Properties dialog window you can see 2 tabs: Common and 

Commissions.   

    

On the Common tab you can change the following settings:   

• Symbol name - name of the symbol.   

• Symbol type - symbol type (Currency pair or Stock).   



 

 

Lot currency - the currency of the lot.   

• Base currency - base currency.   

• Lot size - the cost of 1 lot in the lot currency.   

• Leverage - the ratio between the Lot size and Margin for 1 lot. 

Each brokers uses different leverage so we recommend to use 

the leverage  

that is used by your broker.   

• Post decimal digits - the number of digits after point. For 

example.    

1.2500 is a 4-digit value and 1.25001 is a 5-digit value.   

• Spread, points - spread in points. Spread means the difference 

between Bid and Ask prices.   

• Min distance to price - a minimal distance to the current price 

in points where you can place pending orders.   

Min distance to price” defines two options:   

1. Minimal distance from a current market price where you can place 

pending orders. If you set 20 there and try to place a pending order 

15 points above/below a current price, you will see a message 

indicating  

that open price is too close.   

2. Minimal distance of SL/TP levels. If you set 20 there, you can’t set 

SL/TP levels lesser than 20 points.   



 

 

When placing the order and defining SL, Stop Loss needs to be 

equal or bigger than “Min distance to price”+”Spread” value, in this 

case order will be placed without any problems.   

• Margin currency - the currency of the margin.   

• Margin for 1 lot - the margin for 1 lot.    

Hedged margin - the margin that will be calculated for hedged 

positions for 1 lot. You need to disable Use leverage info option if 

you want to enter the margin values manually.   

   

   

On the Commissions tab you have the ability to set up the next 

properties:   

• Commission per lot, USD – brokers commission when open and 

(or) close positions. Here you can choose the option when to 

apply the commission during testing (according to your 



 

 

conditions): when open and close positions, only when you open 

order or only when you close order. Please note that when you 

close the position partially, the commission the commission will 

be calculated from the part of the position that you want to close. 

The amount of commission after position close you can see on  

the Account History tab at the bottom of the screen.   

• Swap long - the swap for a long position in points.   

Swap short - the swap for a short position in points.   

After you change necessary options please click Ok button.    

3) Information about downloaded data:   

The following dialog allows getting the information about 

downloaded data and change some import properties.    

You can see the elements of this dialog in detail below:    



 

 

    

1. The list of the brokers:   

   
 

This list shows brokers, which data are available for downloading from 

our  

server.    

Attention: the list of brokers differs depending on the subscription 

type   



 

 

(please check the more detailed information about data subscription 

types).  After selecting the broker, you can download accurate data 

from the server by clicking the Update from server button.     

2. Time shift:    

   

This message shows the time zone of historical data. By default, our 

data are provided in GMT+0 time zone; you will be able to change 

the time zone when creating a new project.     

3. Data quality indicators:    

    

   

This part of the window gives the ability to evaluate the quality of 

historical  

data:    

• Green areas displays the quality data without gaps.    

• Red areas mean missing data.    

• "Darkened" parts indicate the presence of small blanks.    

• Oblique lines show that no data have been downloaded    4. 

Data management buttons:    

   

These buttons allow you to perform the following actions:    
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• Update from server button allows you downloading historical 

data from our server. You can find more information about 

downloading the data  

here.    

• Import data from a file button allows you importing historical 

data in files from other sources. Files can have .txt or .csv 

extension. You can find more information about importing data 

from a file here.    

• Export button allows exporting historical data from a Forex 

Tester program into a text file for further processing by another 

application (for example, Excel). Forex Tester allows exporting 

data with any timeframe.   Clear History button allows to 

delete historical data for selected currency symbol(s). By clicking 

this button you can delete minute or/and   

tick history.     

5.Information line.    

     

This part is located in the bottom left corner of the Data Center 

window. Information line displays the connection state to the data 

server. While connecting to the server, you will see the following 

message "Connecting to the data server", and in this moment, we 

do not recommend doing any action with data. Also in information 

line you can see the type of the Data Subscription you are 

subscribed to. You can find more info about the types of data 

subscription and subscribe here.     

http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/import
http://forextester.com/HistoryServiceDescription
http://forextester.com/HistoryServiceDescription
http://forextester.com/HistoryServiceDescription
http://forextester.com/HistoryServiceDescription
http://forextester.com/HistoryServiceDescription
http://forextester.com/HistoryServiceDescription


 

 

6) The News tab. On this tab you can find information about 

available historical news, download them manually or find the link 

for upgrading your subscription.    

   

   

   

You can learn more about news on this page.   

   

   

   

   

   

   

   

   



 

 

Importing data    

Forex Tester allows downloading historical data from our server or 

importing the data directly from text files. We provide free 

historical data starting from 01 January 2001 until the current 

moment. These data can be downloaded via the Data Center 

window in the Forex Tester program or in archives from   

our site.    

Our software converts historical data to a highly timeframes 

automatically, so we recommend importing 1-minute data into the 

program, in this case, you will be able to use these data on any 

timeframes in Forex Tester program.    

Historical data can be imported via the Data Center window only. To 

access the Data Center, please click the “Data Center” button on the 

toolbar:    

   

Or open it via File → Data Center menu:    
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Use the “Update from server” button to download data from our 

server and “Import from a file” button to import the data from a text 

file.    

    

     
Update history from server    



 

 

To download the historical data from the data server, you need to 

select the pair (or multiple pairs) in the list, select the broker and click 

the “Update from server” button. You need to download data only 

once; they will be stored on your local disk once you download the 

data from our server.    

Note that the list of available brokers can vary depending on the 

Data Service type. Basic (free) Subscription allows importing 

historical data for 16 currency pairs + gold + silver from Forexite 

broker only.    

In case if you want to use the historical rates:    

• Of a better quality    

• From 10 most popular brokers    

• With 5 digits after point (3 digits after point for the currency pairs 

that  

contain the JPY symbol)    

Then subscribe for the “Standard” data service.    

If you mostly trade on time frames M1 through M30 then the “VIP” 

data  

package will suit your needs.    

The VIP data service type allows:    

• Using tick data    

• Considering spread    

• Receiving the most accurate and quality results    

You can get more detailed information dedicated to the historical rates 

at this page   
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After clicking “Update from server” button you will see the following 

dialog window:    

   

   

With the help of this dialog you can add your missing data (Forex 

Tester will automatically determine which data are missing for this 

currency symbol), or just download data over some period of time.    

In the Info box, you can see the information about the broker and 

symbol, available data range and the type of data to download. 

Data Server provides two types of history - 1-minute history and 

tick history (which consists of real ticks and gives the best quality 

of testing). Tick history is available only for VIP service subscribers.    

In the Date Range box you can define what part of history you 

want to download. If you select the Download new historyoption, 

then you will get the part of history from the last update. For 

example, if you have already downloaded history up to 01/01/2015 

then the program will download the part of history from 
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01/01/2015 till the last available date and merge new data with the 

previously imported history. This method is very useful to update 

your history time by time, so you always have up to date historical 

data. If you have an empty history (or cleared history before import) 

- it will download all available history for this symbol.    

If you select the Download part of history option, then you will 

get the history for the requested period, this history will be 

correctly merged with the previously imported historical data.    

In the Select data to download box, you can define the type of data 

to download.    

• To download minute and tick history (recommended).   

• To download only minute history, use this option if you just need 

to investigate the data on charts without testing them or if tick data 

are not  

available in your subscription type.   

• To download only tick history, use this option if you want to have 

the most  

precise data for testing.   

Please note: tick history is available only for subscribers of VIP data 

service.    

Please read more info about data service types here.    

Click Update button to start the downloading process.    
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Note: If you have selected a large amount of historical data to 

download, the server will need some to prepare the files.    

You can find the start and end dates of downloaded data under the 

green   

bar:    

   
Import history from a file    

To import the data from a file, please click “Import from a file” button 

in Data  

Center window.    



 

 

   

The Import history dialog allows importing historical data from a file 

into the  

program. Forex Tester can import data from any text file, including 

text format *.csv. The source data should contain bars for a one 

minute timeframe or higher (5M, 1H, 1D, etc). Lower timeframes 

will be incorrect in this case and this can result in a low testing 

quality.    

When you open the Import history data dialog, you will see the 

dialog below:    



 

 

   

At first, please select a file to import by clicking "..." button.    

You can find the data files on our site here     

Once the file is selected, Forex Tester will try to determine the 

destination currency automatically and select the necessary 

currency in Import to symbol: drop-down menu in this case.    

If the file does not contain information about the currency, the 

program will not be able to determine the currency automatically: 

the user needs to select the currency from the list manually.    

Also, the user can use Shift time (hours): slider to change the time 

zone of importing historical data. It is necessary if the user imports 

data from different sources (with different time zones) and wants 

to have the same time zone for all his data.    

You can also activate "Delete the previously imported history for this 

symbol. If you want to add a new history to the existing one - do not 
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check this checkbox" option, in this case our program will delete all 

previously imported  

data for this symbol.    

   

Once everything is set, click the Next button.    

   



 

 

If the text format is selected, the user will see the dialog 

above. The program will try to determine all fields 

automatically, but you can also change them manually.    

• Column separator: this is the character that separates columns in 

the text  

file. Usually, it is comma or semicolon.   

• Date format - the format of the date. YYYY (YY) - year field, MM - 

month  

field, DD - day field.   

• Column1 ... Column10 - data columns. They can contain these 

values:   

Skip    Skip this column  

Symbol   Currency name    

Date    Date    

Time    Time    

Open    Open value    

High    High value    

Low    Low value    

Close    Close value    

Volume   Volume    

• Source file - the part of the source file.   

• Preview results - the results of file conversion.   

Note:     

If columns are defined in a wrong way or some information is missing, 

the user will see a red text indicating the number of errors.    



 

 

    

   

To import history data, click the Import button.     

When our program finishes importing historical data you will see the 

message below:    

    

   

    

      

   

   

 

 

 

 



 

 

Creating a new project   

   

Before the testing starts, you need to prepare historical data for it. 

By clicking New Project button, you will be able to select the 

symbols that you want to test, the time period for testing, initial 

deposit in USD etc.    

For example, you may have downloaded data for 10 currency pairs but 

want to  

test only 2 of them.    

You can select these two pairs when creating a new project and test 

only these pairs for the period from 2012 till 2016 year, for example.    

Please note that you can use real historical tick data during 

testing  

(they are available for subscribers of VIP data service).    

You can start a new project by clicking New Project button or via File 

→ New Project menu in the program:    

    

In appeared Create new project window you can set the name of the 

project  (in Project name: field) and also the initial deposit in USD.    
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After this, please click Next button. The following window will be 

opened:    



 

 

   
In this window, you need to activate the pairs from the list that 

you want to test (you can select all of them using Select All 

button). It is possible to test more than one currency symbol 

simultaneously. In From date: and To date: fields, you need to 

select the start and end dates of the period that will be shown 

during testing.    

Testing quality part of the window is responsible for the quality of 

the data that will be used by our program during testing.    

Select Use minute data if you have them, or Use minute and 

tick data if you have downloaded tick historical data from our 

server (tick data history is available in Premium data service, 

please see details here). This option gives you the best testing 

quality.   
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Click the Advanced settings button to open the advanced settings 

window.   

Two methods of preparing are available:    

Generate ticks by OHLC points – if you select this method, each bar 

will contain 1-4 ticks based on Open/ High/ Low/ Close values of the 

given bar   

(less than 4 ticks are possible in the situation when    

Open=High, or Low=Close).    

Generate ticks randomly by volume – it means that the number 

of ticks inside a 1-minute bar will be equal to the volume of this 

bar, ticks will be distributed randomly inside a single bar. We 

recommend using  the first method of ticks generation, as it is the 

fastest and gives a good testing  

quality.    

If you have activated the Use minute and tick data option, the 

Use floating spread option will be available in the advanced 

settings window. This feature is important for all intraday traders 

(timeframes M1, M5, M15,   

M30, H1) to obtain the most precise test results.   



 

 

   

After you select all necessary parameters, please click Next button to 

continue.  If you created a project for several currency pairs and one 

of them lacks data,  

you will see the following window:   

   



 

 

  

On this step you will be able to see for what period you do not 

have the same data in the project - it is marked in red. In this case 

please click the Download missing history data button and 

download the data for the  

currency pairs of this project and create project again.   

   

If you want to skip this step, just click the "Next" button. Bear in 

mind that you will see the "No data" message on the chart of the 

symbol with missed data after the test begins.    

In the next window, you can select the time zone of historical 

data, use Timezone: slider for this purpose. The selected time 
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zone will be applied to all the selected pairs for testing. Default 

selected time zone is GMT+0.    

You can use the dropdown menu "Session close time" to 

determine the displaying of bars according to the closing time of 

the session that you need.   

The program has 4 predefined Session closing times (Sydney close, 

Tokyo close, London close and New York) and 1 custom time.   

When you select one of the dropdown menu item, the Time Zone slider 

automatically moves to the corresponding GMT.   

By default, when creating a new project, data without applying 

Daylight Saving Time is used. If necessary, you can apply DST that 

matches your region from the drop-down list.   

If you select "Start testing from the first date in range" then 

testing will be started from the date that you selected in "From 

date:" field in the previous window.    

But you can also change the starting date by selecting Define 

first Date to start (preload history before start date) option. 

In this case the testing can be started from a further date (it can 

be selected in Start date: field or by moving Preload days: 

slider) and all previous data will be shown on the chart.    

This option will be useful if you immediately want to build lines/ 

indicators based on previous bars or want to analyze previous data 

and start trading based on them.    
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If you want the testing to start immediately after the project is created, 

activate the "Start testing after creation" option.    

Forward testing only mode option enables mode as close as possible 

to real conditions. This means that you can not go backwards in your 

testing.   

You can only restart this project.   

When you complete the configuration, please click Create button to 

finish the process of preparing data. Test will start automatically.   

If you did not activate the option "Start testing after creation", then 

after that you need to click the "Start testing" button and the testing 

process will be  

started.   
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If you need to add new historical data to an existing project, please go 

to the Project -> Download and Update New History menu. Forex 

Tester will  

analyze your downloaded data and if it is not enough to add it to the 

project the program will update it from our server according to your 

subscription. So, you no longer have to upload this data through the 

Data Center and recreate  

the project.   
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Start testing    

After importing historical data and preparing data for testing by 

creating a new project you can start testing some trading strategy. To 

start testing,  

please press the "Start Test" button    

  

after this, the testing will start immediately, and you will see the 

moving bars on the chart(s).    
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When the testing is started, the "Start Test" button will be changed 

to   

"Stop Test"  button.    

Now you can test your trading strategy by placing orders and see 

how the strategy works (see the next tutorial about how to place 

orders). You can change the speed of testing, pause it and draw new 

bars by pressing a button with the next control bar:    

   

1. The pause button - you can set pause mode to pause price 

changing and analyze the situation. Also, Pause mode enables 

buttons 4, 5, 6. The pause could be set and released with the 

"Pause" button on a  

keyboard.   

2. The speed of price changing. By moving this track bar, you 

define how  

fast your testing time goes.   

3. Tick package size. Here you can set how often to update charts 

if you set Every tick - charts will be updated after every tick 

processing if you set 15 minutes - charts will be updated after 

processing 15 minute-  

tick- package. It also affects the speed.   

4. Move back by a single bar. This button is available only when 

the Pause set. It will delete 1 bar in terms of the current time 

frame. If the current time frame is 1 hour - you will go back 
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for 1 hour, if you had some closed trades they could be 

restored. You can also use the "Backspace"  

button on a keyboard for this purpose.   

5. Move forward by a single bar. This button is available only 

when the Pause set. You will go forward on 1 bar in terms of 

the current time frame. If the current time frame is 1 hour - 

you will go forward for 1 hour. It affects all the charts. You can 

also use the "Space" button on a  

keyboard key for this purpose.   

6. Move forward by tick package size. This button is available 

only when the Pause set. You will go forward on time defined 

by the tick package  

size (3). You can use the "F11" button on a keyboard for this 

purpose.   

Note: you can change the hotkeys for these, and other actions via 

Tools →  Options menu, Hotkeys tab.    

The program has the opportunity to search the necessary date and 

time of the current project. Please use the Search date/time button 

  to open the “Search date/time” dialog window (or use the View -

> Search date/time menu)   
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In the Date/time field you can specify date and time which you`re 

looking for. You have the ability to find this date on the current chart 

only or in all charts involved in the project.   

This is a visual testing mode when you can see your trades and place 

them manually. Forex Tester can also test automated strategies 

written with C++ and Delphi. You can find API and examples how to 

write custom indicators and strategies in the \Examples\ folder after 

installation.    

Also you can try out our great tool for strategy development Visual 

Strategy Builder. The main task of this program is to give a possibility 

for every trader, without reference to their coding skills or trading 

experience, to create an expert advisor that would match their 

personal preferences; modify and refine as much as the trader needs.   

You can backtest automated strategies with the Fast Test option.   

      

Placing Orders    

   

After starting the test, you can place orders in the program. There 

are two types of orders - market orders (when you immediately open 
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a position by the current market price) and pending orders (when 

you place an order at some price and it will be triggered when the 

market price hits this level). You can place, modify or delete orders 

with help of this toolbar:    

   

   

1. Place new market order - opens the market order dialog (you can 

also  

use F2 button on a keyboard).    

2. Place new pending order - opens the pending order dialog (F3).   

3. Modify order (F4) - you need to select an order first in Open 

Positions or Pending Orders tabs. This feature allows you to 

change stop loss and take profit parameters for already opened 

market orders. For pending orders, you can change not only stop 

loss/take profit levels but also the entry price  

of this order. Also, you can use this window to close the trade.    

4. Close selected position - closes an open position (F5). You need 

to select  

an order first in the Open Positions list.    

5. Close part of selected position – partially closes the order 

(Ctrl+F5). You  

need to select the order at fist in the Open Positions tab.    
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6. Close all positions and orders (Ctrl+C) – closes all opened market 

and pending orders from Open Positions or Pending Orders tabs.    

7. Delete pending order – deletes a pending order (F6). You need to 

select  

a pending order first in the Pending Orders tab.    

8. Place group of orders (Ctrl+O) – places a group of orders with 

predefined parameters.   

These buttons are duplicated with the Orders menu:    

   

Market order dialog. With this dialog, you can place a new market 

order. Use droplet buttons to pick up the price directly from the 

chart. You can also type the price directly or use a simple calculator 

on the right to calculate Stop Loss and Take Profit values. Radio 

buttons “sell” and “buy” are used to define the calculation mode - 

Sell or Buy. With the "Risk" and "Lot" radio buttons you can choose 

how to calculate the lot - manually or based on risk  

management. Note that if you choose a risk-based lot calculation, you 

should enter a stop loss value. Trailing stop bookmark allows you to 

define trailing  

stop parameters for this order.    
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Pending order dialog. With this dialog, you can place a new 

pending order. Use droplet buttons to pick up the price directly 

from the chart. You can also type the price directly or use a simple 

calculator on the right to calculate Stop Loss and Take Profit values 

(the order type will affect these calculations). Use the "Risk" and 

"Lot" radio buttons to change the way the lot is calculated - 

manually or based on risk management. If you choose a risk-based 

lot calculation, please enter a stop loss value. Trailing stop  

bookmark allows you to define trailing stop parameters for this order.    
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Also, you can place orders with the right mouse click on a chart and 

with the use of a popup menu:    
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This menu allows you to pick up the price from the chart at that point 

where you click with the right mouse button. It shows this price in 

the menu as you can see (1.2833). In this example, you have 3 choices 

- you can Buy with the predefined stop loss at 1.2833, place Buy Limit 

order at this price or place Sell Stop order at this price.    

There are two other options to place orders - you can make quick 

buy or sell with predefined parameters. It is better to use hotkeys for 

this (Ctrl+B and Ctrl+S), it allows placing orders very fast with lots of 

the predefined  

parameters like stop loss/take profit, trailing stop and lot size. You can 

define these parameters in the menu Tools → Options → Default 

orders:    
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If you set there only 1 order in the list, then after pressing 

Ctrl+B/Ctrl+S, the order will be set immediately, Otherwise you will be 

asked to choose which  

order to execute:    
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Modifying Orders   

After placing one or several orders (market or pending), you can 

change most of their settings. For market orders, you can change the 

stop loss and take profit levels, for pending orders, you can also 

change the market price. Also, you can modify trailing stop 

parameters for both types of orders. If you placed only one order, 

you can modify it by clicking the Modify order button on the toolbar 

(or pressing the F4 button on a keyboard). If you placed some orders, 

you need to select an order in the Open Positions or Pending 

Orders list at   

first:   
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After this, you can click the Modify order button on the toolbar (or 

press the   

F4 button on a keyboard):    

   

   
Or click the right mouse button on order and select “Modify Order” 

option  

from a drop-down menu.    

   

   

Or you can double-click the left mouse button on the order, in this 

case, the chart will be moved to that time when the order is placed, 

and this time, will be highlighted with a vertical line and a “Modify 

order” dialog will be opened. This is the dialog for a market order, 

with this dialog you can modify Stop Loss and Take Profit 

parameters (the parameters that can’t be modified are grayed out). By 

clicking the “Close position” button, you can close the  

order.    
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This dialog is for a pending order, and with this dialog, you can modify 

its  

parameters or delete a pending order:    

   

Also, you can use the toolbar buttons, hot keys or drop-down menu to  

close the position or delete pending orders.    
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Also, you can move the SL/TP of market orders and also the execution 

price of  

pending orders by drag-n-dropping the lines on the chart.    

   
   

   

   

   

Using Indicators   

You can add an indicator or oscillator to the chart with the help of this 

button  on the toolbar or with help of Insert → Add Indicator 

menu:    
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In addition, you can click the right mouse button on the chart and 

select the "Add Indicator" item.   

For convenience, the indicators are divided into 7 groups according 

to the  

functions:   

1. Trend indicators   

2. Oscillators   

3. Volume indicators   

4. Volatility indicators   

5. Adaptive indicators   

6. Custom indicators   

If you add your own indicators, you can find them in the Custom 

indicators submenu.   

 You will see the dialog where you can modify indicator's properties 

before it  

is placed on the chart:    
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To modify an indicator’s parameter, you need to double-click on it 

or click the left mouse button and press the "Enter" key. Some of 

the properties may have the drop-down list or a dialog window 

where you can select some  

values:    

   
To cancel changes, press the "Esc" button on the keyboard, and to 

apply them press the "Enter" or "Tab" button, or click the left mouse 

button on  

the dialog.    

    

Each indicator is linked to one timeframe of the chart window. So, if 

you place it on the H1 time frame, you will not see it on other time 

frames (15 min, 1 min, etc.). It was done for optimization purposes, 

if not, it would slow down the testing process significantly. We 

recommend you to place indicators only on those time frames where 
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you need them. You can do it with the help of "Timeframes" tab, 

activate the needed timeframes here:    

     

To edit the indicator on the chart, please click the right mouse button 

on the indicator's line, you will see the next menu:    

   

You can edit indicator's properties (select “Edit …” option in this case) 

or delete it from the chart (“Delete …“).    
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You can combine more than 1 indicator in the oscillator window. 

Click the right mouse button in the oscillator window and select 

"Add indicator to window". When you delete the oscillator's 

window, all other indicators in this window will be deleted too.    

   

Also, you can see and manage all the indicators on all charts and 

timeframes  

with the help of “List of indicators” button on the toolbar:    
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Here you can edit indicator properties, delete indicators, or delete all 

indicators on all charts at once.    

We included lots of standard indicators into Forex Tester, but if you 

need any of the custom indicators that is not included in the program, 

you can create it by yourself or hire a programmer who can do this 

job. Looking for someone to code an indicator / EAs or Expert Advisor 

from the scratch for you? Check the available opportunities here   

Custom indicators in .dll format can be installed with the File → Install 

File →  → Install indicator menu.    

   

In case of successful import you will see the message: Indicator 

installed.   

https://forextester.com/hire-an-mt4-programmer
https://forextester.com/hire-an-mt4-programmer
https://forextester.com/hire-an-mt4-programmer
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After importing you can find your indicators in the Insert → Add 

Indicator → Custom menu.   

The list of built-in Forex Tester indicators:    

1.1 Trend indicators:   

• Adaptive Moving Average 2 (AMA2)  Alligator   

• Bollinger Bands   

• DeMarker   

• DonchianChannel+Midline   

• Envelopes   

• HeikinAshi   

• HMA Colored   

• Ichimoku    

• Keltner Channel   

• Linear Regression Channel   

• MA Crossover Signals   

• MA Colored   

• Moving Average   

• Moving Average+Levels   

• Parabolic SAR   
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• Price Channel   

• Pivot Points   

• ZigZag   

 

1.2. Oscillators   

• Accelerator Oscillator 

• Aroon 

• Average Directional Movement Index 

• Awesome Oscillator 

• Bears Power  

• Bulls Power   

• MACD   

• MACD new   

• Momentum   

• Polarized Fractal Efficiency (PFE)   

• Rate of Change (ROC)   

• Price Daily Range   

• Relative Strength Index   

• Solar Wind   

• Trade dynamic index (TDI)   

• Williams' Percent Range   

• Ultimate Oscillator   

 

1.3. Volume Indicators:   

 

• MarketProfile(old)     

• Market Facilitation Index  

• Money Flow Index      

• On Balance Volume      

• Volume   

 

1.4. Volatility : 
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• ADR   

• Average True Range   

 

1.5. Adaptive   

 

• FATL (Fast Adaptive Trend Line)   

 

1.6. Custom  

 

•  ATR_MA   

• Bollinger Bands %b   

• Commodity Channel Index (CCI)   

• Elder`s Force Index   

• Engulfing Bar   

• Fractals (B.Williams)   

• FTLM-STLM   

• Gann HiLo   

• I-Sessions   

• Inside Bar 

• Ishimoku   

• PCCI   

• Range bars   

• Range Expansions Index   

• Stochastic   

• Time box  

  

This list of indicators is not final. It will be updated as the new 

indicators will be added to Forex Tester 4.   
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 Using Graphic Tools   

Forex Tester has a large variety of charting tools such as:    

• Pointers (arrow pointer, crosshair pointer)   

• Lines (Vertical line, Horizontal line, Trend line, Ray, Poly line)   

• Shapes (Rectangle, Ellipse, Triangle)   

• Signs (Thumb up, Thumb down, Arrow up, Arrow down, Stop sign, 

Check   

sign, Right price label, Left price label, Price label)   

• Fibonacci tools (Fibonacci retracement, Fibonacci time zones, 

Fibonacci  

fan, Fibonacci arc, Fibonacci extension)   

• Channels (Fibo channel, Linear regression channel)   

• Andrews' Pitchfork   



 

114   

   

• Text label   

• Wave symbols   

You can find all of them in the "Insert" menu:    

   

   

Also, you can find all these graphic instruments on the toolbar:    

   

   

You can see an icon on the toolbar:    

      - this icon enables a "crosshair" mode. The crosshair lines 

are movable lines that can be used to specify and measure positions 

on the chart. If you hold down the left mouse button in the crosshair 

cursor mode and drag it to one of the sides, you can get the 

following information:   

1) the number of bars between the start and end point of the 

crosshair;   

2) price change in pips and percentage;   
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3) the interval between the start and end points of the cross in days/ 

hours/ minutes.    

   

   

   

 - this icon sets a magnet mode. If this mode is activated, then 

the mouse pointer will stick to the Open/High/Low/Close values of 

the nearest bar on the chart. You can set a magnet sensitivity in the 

chart options (click the right  

mouse button on the chart and select the “Chart Settings” option).   

 - this button enables synchronizing crosshair on all charts. If this 

mode is activated, the crosshair mouse pointer represented on all the 

charts with all time frame differences kept.  To enable/disable Global 

Cross Hair Cursor, click the button on the toolbar. Then use Crosshair 
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cursor as always.  

   

Drawing of the lines is pretty easy: select the tool and then click 

once with the left mouse to set the first point (in the case of the 

Vertical and Horizontal lines it will be only 1 point) drag your mouse 
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and click to set the second point. If you decide to cancel drawing - 

just click the right mouse button - it will cancel the operation. Some 

tools like Poly line or Andrews' Pitchfork require more than 2 points 

to place.    

Each tool has its own properties. To edit them, right click on the tool 

and select Edit tool. You can also duplicate this tool or delete it with 

the help  

of this menu.    

   

To select the tool, please double-click on it with the left mouse 

button. You will see white points which you can move to change the 

shape and position of the tool. If you press the Delete button on the 

keyboard, then all selected tools in this chart window will be deleted. 

To deselect the tool, double-click on it with the left mouse button 

again.    

There are some hotkeys that will help you to manage graphic tools:    



 

118   

   

Ctrl + G - to select all the tools on the chart.    

Ctrl + D - to deselect all the tools on the chart.    

Ctrl + Del - to delete last added tool.    

Ctrl + A - to delete all the tools on the chart (selected or not).    

Delete - to delete only selected tools on the chart.    

Note that all the hotkeys can be changed via the Tools → Options 

menu.  You can see these shortcuts through the Edit menu. Also in 

this menu, you can open the List of objects where you will see all 

tools that are currently  

added to a selected chart and change or delete any of these tools.    

   

The Objects list dialog has the following view:    

   
To synchronize graphical tools on all charts and timeframes of one 

currency pair, use the button    on the Paint toolbar.    
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When this mode is active all new graphical objects created on the 

one of the charts will appear on all of the charts with the same 

currency pair.   

Using Templates and Desktops   

   

Template is a complete set of one chart window's configuration, 

including indicators, painting tools and chart color scheme.    

You can use templates to make your testing easier and more 

comfortable use. When all settings are put up, you can save your 

template. To save template you should:    

1. Click on View:   

   

2. Select Templates → Save Template, or click the right mouse button 

on  

the chart and select Templates → Save Template:    
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3. Type the template's name and tick the necessary item, for instance, 

as itis shown below:    

Save options:    

- Save color scheme: saves the color scheme, both main and additional  

colors of the current chart.    

- Save graphic instrument: saves all graphical tools.   

- Save indicators: saves all chosen indicators.   

   

→ it will save the colors of the chart, bars, grid, etc. (indicators will not 

be  

displayed on the chart - only color scheme will be saved);    

   

→ it will save all indicators for all timeframes of the current window;   



 

121   

   

   

→ except color scheme, it will save all graphic instruments: lines, 

Fibonacci tools, Shapes, Channels, Text Labels, etc.    

Please NOTE: you can uncheck and select the necessary item (as shown  

above), or just leave it by default:    

   

If to apply the template to another currency, so it's better to exclude 

the  

option - Save graphic instruments - as they will be copied in a  

nonappropriate way:    
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Please NOTE: indicators are attached to specific timeframes in 

comparison to other platforms where they are not attached at all. So, 

if you save a template for 15 minutes, 1 and 4 hours timeframes, then 

after applying this template, the indicators will appear on these 

timeframes only.    

To apply the template, please click the right mouse button on the chart 

→  

Templates → < Name of the template >:    
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Please NOTE: The chart is changed according to the Template, the  

timeframe shifts to the same one as was saved in your template. That 

means that the template saves a complete state of the chart including 

timeframes and indicators that can be applied to the selected 

timeframes only.    

To rename or delete the templates:    

1. Click the right mouse button on the chart.   

2. Select Templates → Edit Templates:   
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3. You will see the list of templates. Select the template you need from 

this   

list:    

   

4. Click → Rename, make changes and confirm them:   
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To delete the template, click the Delete button and confirm the deletion 

of  

the template:    

   

You can also check out your templates via the View → Templates 

menu:    
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When clicking on Templates → default, the chart gains the default 

settings:    

   

If you want to move your templates from one computer to another, 

for instance, go to Forex Tester 4 folder (C:\ForexTester4 folder by 

default) → Select the Templates folder and copy all your templates 

to some additional folder on your computer in order to restore them 

when it's necessary.    
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Forex Tester program allows saving the charts, indicators and graphical 

instruments as a single file and then load this file again to restore all 

necessary configuration.   

For example, you can add 4 charts in the program, add an indicators and 

graphical instruments onto these charts and then save them as a desktop  

on your local disk.   

The desktop can be saved via File -> Save Desktop menu   

   

After this, you need to enter the name of a saved desktop and select the 

folder where the desktop will be saved.    

The desktop file has a .dsk extension.   

You can load a saved desktop via File-> Load Desktop menu.   
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Please note that the desktop will be applied only to the currency pair it 

was initially saved for. If you save the desktop on a particular currency 

pair, and then select a new currency pair when creating the project - the 

desktop will not be applied. The program will warn you about it with the 

information message, which you can turn off by checking the box Do not 

show this message next time.   

   



 

129   

   

   
By selecting Restore Default Desktop you will load the default 

desktop. Please note that this will delete your chart so we 

recommend you to save graphics from your chart as a template via   

View -> Templates -> Save Template menu   
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Save projects   

Project is a saved testing strategy with all its features inclusively. Project 

saves all its structure with orders, charts, and indicators which were placed 

on these charts. And after opening the project, it restores its entire saved 

features & elements. For convenience and ease, you can save your current 

project in this way – Go to File → “Save project” or File → “Save Project  

as…”    

   

Type the project’s name, and click Save:    
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Then you’ll see the project’s name in brackets:    

    

To open your saved project: Click File → Open Project:     

     

You’ll see the window with the list of saved projects. Select the project you 

need and click Open:    
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You can use such a point of restoration to save some essential parts while 

testing the same strategy, and then when it is necessary, to reverse to any 

of its points you have saved.    

Use two buttons on the Toolbar:    

    

    
   Open project    and Save project       

    

Project restoration saves your time: you can save just your strategy project, 

or even a couple of parts of one and the same strategy, and then come 

back to any saved point any time you wish. It’s easy, quick, and practical 

and gives you an opportunity to simply save the point you want or freeze 

some interesting trading spot.     
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You can start a current project from the beginning or from the necessary date 

in any time of testing.   

To do this, please click Restart current project button   in the Forex   

Tester program or go to the Project – Restart project from date menu.   

   

In the opened dialog window please enter the necessary date and time for 

restarting the project or leave the default value to start your project from the 

beginning.   

   

   

Please note that this action will delete all your current trades and account  

history.   

After restarting you need to click the Start Test button to start testing.   
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Expert Advisers   

An Expert Adviser is the program that is based on some trading strategy, and 

can open and close the trades automatically.    

To backtest the EAs that are already included into Forex Tester, navigate to 

the "Testing → Strategies list" menu. Or you can click on the "List of 

Strategies" button on the toolbar.    

   

Make sure that the strategy execution is enabled. The "Enable / Disable 

strategy execution"  button on the toolbar should be active. Another 

way to enable this feature is to navigate to the "Testing → Enable / 

Disable strategy execution" menu.    

   

We will cover the topic of Expert Advisers on the "Awesome Expert  

Adviser" strategy example.    

1. Click the "List of Strategies" button on the toolbar and check the   

"AwesomeEA " checkbox   
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2. Double-click on the strategy’s name or click on the Properties button.   

3. Choose the symbol from the drop-down menu. If the symbol that you 

need is not available in the drop-down menu then you need to navigate 

to the "Data Center" and download or import the data for this particular 

currency pair, then create a new project for this symbol or load an  

existing project.   

   

4. Select the time frame where you want to test this strategy   
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5. Set up a lot size   

6. Pick the Fast (F) and Slow (S) periods for moving average   

7. Select the type of moving average and price for applying 8. Click "Apply"    

     

9. Click "Close"   
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10. Click the "Start Test" button   

   

Forex Tester will open and close orders automatically due to the strategy rules 

that were programmed in the Expert Adviser.     
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To add a custom EA file that has a .dll extension, please navigate to the    

"File → Install → Install new strategy".   



 

139   
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Statistics and Account History   

The statistics on the strategy’s performance is displayed during the test 

and after the testing is finished. The "Statistics" window shows the most 

important indicators such as:    

• the number of total profit and loss trades   

• maximum profit and loss trade   

• net profit   

• profit per month   

• average profitable and losing trade   

• maximum drawdown   

• and many others   
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Profit chart is an individual chart that contains the specific candlestick chart 

and three additional lines:    

1. The Balance line, the green one, displays your deposit’s changes.   
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2. The Margin line is colored in gray.   

3. The Drawdown line is painted in red color.   

4. The Equity chart is a set of candlesticks that gives a visual  

comprehending of how the equity has been changing.   

   

The main difference between the balance and equity is that the balance 

line can be built only when the trade is closed whereas the equity line 

shows all the changes in the account for the opening trades.    

You can export Profit chart to file or excel for further analysis. Just use 

rightclick in any place of the chart and select Export Equity to a File/ Excel.   
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Use right-click on the "Statistics" window, and you will be able to export 

these data to Excel or to a .txt file. To disable statistics window please go to 

View → Show panels → Statistics.    

     

You can see your Profit and Loss in points on the Account History tab in the 

“Profit/Loss” row.   
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There are different filters in Account History to make your trading analysis  

more convenient. Just click on the Show filters button.   

   

Apply one of the represented filters:   

1. Date filter - show orders by Open, Close, Open and Close, Open or   

Close dates.   

2. Symbol - show only selected symbols   

3. Type - show only Buy or Sell or All orders   

4. Profit - show all or only profitable/unprofitable orders   

Then click Apply to filter the values, or Clear to reset the filters.   
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Also, you can export the account history to Excel or text file by clicking the 

right mouse button on the Account history tab and selecting a necessary 

export option.    
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Using News Service   

You can make use of news calendar in Forex Tester 4.   

The news is updated automatically every time the Dana Center is opened. 

You can see the animated icon of gear during the updating process in the 

lower left corner of the window.   

    

   

   

On the News tab of Data Center window you can see on the left side - the 

list of currencies for which data is provided on our server, on the right side 

- 3 bars indicating the availability of news according to your subscription: 

high, medium and low importance. Each of the bars displays the start and 
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end dates of the available news: if the bar is green, data for that period has 

already been downloaded. If the bar is gray - the news for the period 

specified under the bar is available on the server. Date and time when the 

news information was last updated are displayed under the bars.   

Please note that in the Basic(Free) subscription, only news of USD currency  

is available.   

All other currencies are available in Standard and VIP subscriptions. To 

subscribe to Our Paid Data Service, click the Upgrade Subscription button. 

The Update News from server button allows you to immediately update 

the news, if for some reason they have not been updated automatically.   

By default, the news displaying is enabled and they are represented at the 

bottom of the chart as flags. The color of the flag border (red, yellow, green) 

indicates the importance of this news.    

   

   

   

For example, a red flag border - high importance news, after issue this news 

you can expect a sharp fall/jump rate of the currency pair influenced by this 

news for which it was announced the actual value.   
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The yellow flag border means the middle importance of the news, after its 

release you can also expect a sharp jump or fall.   

Green flag border - low importance, sharp fluctuations of the rates should not 

be expected.   

To disable the displaying of news on the chart please use the right-click 

mouse button and uncheck the “Show news” item or use Right Mouse Click 

=> Chart settings => Settings => uncheck the “Show news” option.   

   

   

In the Chart Settings window -> All charts tab you can enable filtering 

news by chart currency. Just enable corresponding option and you will see 

only news of currencies involved in the chart.   
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You can find the News tab at the bottom of the screen. By default, it is to the 

left of the Journal tab.   

On this tab you will find the following columns:   

• Time - date and time of the news release   

• Country - the country to which this news relates   

• Event - the name of the news   

• Priority - the importance of the news.    

• Actual - the actual news value   

• Previous - the previous news value    

• Forecast - the forecast news value   

All the news on the News tab and on the chart are synchronized. When you 

click on the appropriate line of the News tab, it becomes highlighted and the 

chart goes to the corresponding news icon (flag) on the chart. In this  
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case, this flag is marked with a white vertical line.   

   

Hovering the cursor on the corresponding news flagon the chart shows popup 

with information about the news.   

If several news for different symbols come out at one time, the news icons 

collapse into one icon of the Earth.    

If the news displayed at the same time is more than 1 you can see a number 

on the icon indicating the quantity of news at a given time. Hovering over 

this icon shows you a pop-up window with information of these news. For 

your convenience of using the news in your trade strategy, you can use the 

filters on the News tab.   

   

Just click on the "Show Filters" button.   
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By clicking on the drop-down lists near the filter names, you can select:   

• Date and time of displayed news;   

• One or more symbols that are involved in the project;   

• Show only high, medium or low important news.   

When you click the "Apply" button, all the selected filters are applied to the 

list and to the news displaying on the charts within the project.   

   

   

   

   

   

   


